Verification is currently underway for the maintenance items.
Posted Feb 26, 2025 - 18:38 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 26, 2025 - 18:00 GMT
Scheduled
During this maintenance window, the service will be unavailable for a short period of time. The expected downtime will be approximately 10 minutes during the maintenance window. The service will resume normal operations following this window.
Posted Feb 19, 2025 - 12:09 GMT
This scheduled maintenance affected: secure.uk2.backdrop.cloud, Email Service, and Device Connectivity.